CentOS官网发布CentOS 6.6最新更新版本

10/30/2014来源:软件下载教程人气:6347

虽然 RHEL/CentOS 7 已经发布一段时间了,但是 6 系列仍然在继续更新和维护。2014年10月28日,该系列跟随其上游版本在CentOS官网发布了其最新更新版本 CentOS 6.6。但是,目前使用 RHEL/CentOS 6 的生产环境迁移到 RHEL/CentOS 7 还需要很多工作,RHEL/CentOS 6 系列应该会和 RHEL/CentOS 7 共存很长时间。

CentOS:

  CentOS 是企业 linux 发行版 Red Hat EnterPRise Linux(RHEL)的源代码再编译版本,RHEL是很多大型企业采用的操作系统,但需要向RedHat购买使用权,有偿享受技术支持、版本升级等。从某种角度看,CentOS可以看作是免费版的RedHat,任何人可以自由使用,不需要向RedHat付任何的费用。当然,同样也得不到任何有偿的技术支持和升级服务。

  CentOS 非常适合那些需要可靠、成熟、稳定的企业级操作系统,却又不愿意负担高昂技术支持成本开销的用户。典型的 CentOS 用户包括一些中小企业和个人,他们并不需要专门的商业支持服务,以最低的成本就能开展稳定的业务。

 CentOS 6.6的主要改动如下:

  强化对 SCSI 设备的处理,有助应付某些指令。

  OpenvSwitch 模块现在已成为内核模块。

  新增 HyperV 长驻程序有助 CentOS 在微软 HyperV 主机上运行。

  作为科技预览,6.6 可以在微软的 2012R2 HyperV 上以第二代 VM 的方式运行。

  全面支持 keepalived 及 haproxyd。

  新增 Intel Wildcat 平台的支持。

  新增 OpenJDK 作为科技预览。

  降级功能

  下列组件在 CentOS 6.3 已被降级,并且已从 CentOS 6.6 中删除:

  mingw-gcc

  mingw-boost

  mingw32-qpid-cpp

  下列组件已被降级,并有可能在未来的发行版本中被删除。它们将不会再获更新:

  python-qmf

  python-qpid

  qpid-cpp

  qpid-qmf

  qpid-tests

  qpid-tools

  ruby-qpid

  saslwrapper

  已知问题

  由此发行版本起 X.org 显示驱动程序的 ABI 有所更改,可能会导致 X-session 失效。如果你采用第三方驱动程序 —— 例如:vBox 附加程序、nVidia、ATI 或 ELRepo —— 你须要确保已装入兼容的驱动程序。针对 vBox,你只须重建 vBox 附加程序及重新引导 X-Sesison 已能解决问题。此问题不涉及采用 CentOS 附带缺省驱动程序的用家。

  就 Intel 及 AMD 的处理器结构而言,CentOS 6 仿效上游的要求,规定 32 位元的 x86 芯片必须支持 PAE。

  安装程序须要至少 406MB 内存才能运作。文字模式会自动被应用于拥有少于 632MB 内存的系统上。

  相比起图像安装程序,文字安装程的功能受到局限。尤其是它不支持设置分区的分布、存储方式、或选择组件。详情请参考官方文档。在这里你可以找到一些有用的数据关于如何创建及应用 kickstart 档,它们不需图像安装程序便能完成高级的安装设置。

  Insufficient memory to configure kdump! 这个消息在安装时会出现。这个已知的问题出现在少于 2GB 内存的系统上。你不用理会它。

  i386 及 x86_64 结构的内容均被分为两只 DVD。我们尝试令所有基本服务器及基本桌面安装只需要 DVD-1。

  当你把公钥转转到一台启用 selinux 的 CentOS 6 服务器时,请确保它拥有正确的 selinux 脉络。否则 selinux 或许会拒绝对 ~/.ssh/authorized_keys 进行访问,进而导致金钥验证失效。你可这样设置正确的 selinux 脉络:

  restorecon -R -v /home/$ACCOUNT/.ssh

  CentOS 6 的 ssh-copy-id 知道关于 selinux 脉络,因此上述的权宜之计是没有必要的。

  很多人投诉新缺省的 NetworkManager 工具不会自动启用 Ethernet 界面。请参阅CentOS-6 常见问题集 #2。

  整只 x86_64 安装 ISO 及 minimal ISO 都能在 EFI 硬件上引导(详情请参阅 CentOS 错误 #0006321)。

  有数个组件的名称含 .centos. 字眼却未曾被修改,详情见 CentOS 错误 #0005281。以下是在 6.5 内仍受影响的 SRPM:

  at-spi

  gtk2-engines

  libcanberra

  libgail-gnome

  若要利用 USB 存储器进行安装,你可利用 dd 把个别 ISO 档复制至 USB 存储器的设备名称(而不是分区)上。这个步骤会盖过整支 USB 存储器。以下是 DVD1 的例子:

  dd if=CentOS-6.5-x86_64-bin-DVD1.iso of=/dev/sdb