qmail Vpopmail And sqwebmail HOWTO - 3:获得各组件

12/3/2006来源:Qmail人气:7617

3.1:基本系统的RPM包
3.2:vpopmail
3.3:qmailadmin及相关支持包
3.4:vqsignup
3.5:sqwebmail

一个最基本的原则是:尽量使用相应软件的stable版本,或是最新的发行版。最新版通常包含了增加的新功能,但是还没有能够稳定下来,一些小的Bug会在使用的过程中被不断发现。而stable版则可以放心的使用,不必担心出现讨厌的 Bug(当然,也许只是因为还没有被发现而已)。

3.1:基本系统的RPM包

qmail基本系统采用Dan Kuykendall的src.rpm发行包来构建,Dan Kuykendall包装了很好的src.rpm,它们可以适应RedHat6.2-7.1的发行版,如果你有特殊的需求,你也可以根据他的发行稍作修改,以适应你的特殊平台。

以下是Dan Kuykendall的发行目的:

Untroubled software stands for the following ideals:

1:Untroubled software should be both free from known security defects and designed in such a way that theoretical attacks are difficult or impossible to mount, just as the term "untroubled" is a synonym for "secure".

2:Untroubled software should be fault tolerant. Failures in underlying or related systems must not cause loss of data and should not cause interruption in service.

3:Untroubled software should not introduce faults into the Operation of other software (unless it is specifically designed to do so).

4:Untroubled software should not cause trouble with unusual or erroneous behavior. The behavior of untroubled software should be strictly deterministic.

5:Untroubled software should be unencumbered by restrictions on access to or distribution of its source code, or by restrictions on the use of intellectual PRoperty contained therein (by, for example, patents).

所有以下包都可以从http://untroubled.org得到,推荐你使用Dan Kuykendall的发行包:

qmail-1.03+patches-18.src.rpm

ucspi-tcp-0.88-1.src.rpm

ucspi-unix-0.34-1.src.rpm

daemontools-0.70-3.src.rpm

supervise-scripts-3.3-1.src.rpm

注意:ucspi-unix-0.34-1.src.rpm对于本文档是必须的,虽然qmail可以不使用ucspi-unix!

如果你一定想通过源码建造整个系统,推荐你一定要精读Life With qmail!

3.2:vpopmail

vpopmail可以从http://www.inter7.com/vpopmail/得到,目前的stable version是 vpopmail-4.9.10。

由于对MySQL、sqwebmail的支持等原因,最好是使用 vpopmail-4.10.X 版本,目前的 Development Version 是 vpopmail-4.10.27。

http://www.inter7.com 的所有Development Version 可以从以下得到:

http://www.inter7.com/devel/

其中包括:vpopmail,qmailadmin,vqadmin。

注意:vpopmail-4.10.X 必须同 qmailadmin-0.5X 版本一起工作。

3.3:qmailadmin及相关支持包

qmailadmin可以从http://www.inter7.com/qmailadmin/得到,目前的stable version是 vpopmail-0.45。Development Version 是qmailadmin-0.57。

注意:vpopmail-4.10.X 必须同 qmailadmin-0.5X 版本一起工作。

qmailadmin需要以下软件的支持:

autorespond

ezmlm

ezmlm-idx

autorespond-1.0.0.tar.gz 可以在以下得到:

http://www.inter7.com/qmailadmin/

ezmlm 可以从 www.ezmlm.org下载。" target="_blank">http://cr.yp.to/ezmlm.html得到,或者可以直接从www.ezmlm.org下载。

ezmlm-idx是ezmlm的扩展,下在地址:www.ezmlm.org,推荐你下载ezmlm-idx-0.40.tar.gz,不要下载rpm包。

我认为ezmlm-idx-mysql-X.src.rpm或ezmlm-idx-X.rpm包制作的不是很好,使用不善,可能造成安全问题,请大家不要贪图方便,还是使用.tar.gz比较好。

inter7.com提供了一个qmailadmin的add-on,vqadmin,vqadmin-1.9支持vpopmail-4.9.X,vqadmin-1.14支持vpopmail-4.10.X。

vqadmin用于补充qmailadmin的管理功能,主要用于:

Add / Delete virtual email domains.

Change user passWords, quota's.

Turn off account services such as pop, imap, web email or smtp relay.

从这里下载!

vqadmin可能会带来安全问题!

3.4:vqsignup

vqsignup可以从http://www.inter7.com/vqsignup/得到,最新版本是 vqsignup-0.5。

3.5:sqwebmail

sqwebmail是Courier mail server的一部分,目前版本是 2.1.1 。Download from http://www.courier-mta.org/download.php#sqwebmail,or HTTP or FTP。

如果你想使用sqwebmail的邮件过滤(mail filtering),你必须安装maildrop作为传输代理,maildrop是Courier mail server的一部分,目前版本是 1.3.3 。Download from http://www.courier-mta.org/download.php#maildrop,or HTTP or FTP。

如果你使用vpopmail4.10.X,你必需更新preauthvchkpw.c,更新版本的preauthvchkpw.c从这里下载!

,